next up previous
Next: 4. Quick Intro Up: IMUNES manual Previous: 2. Introduction

Subsections


3. User Interface Layout

IMUNES can be used either through the simple Tcl/Tk based graphical user interface (GUI) or through the command line interface (CLI).

We will run IMUNES on FreeBSD with some kind of X11 window manager and explain the main GUI components. If X11 is not running you can start it using startx command. To run IMUNES GUI use imunes command.

IMUNES GUI is a simple Tcl/Tk based management console, allowing specification and management of virtual network topologies. Its main parts are the work space in the middle, called canvas, the menubar on the top, the toolbox on the left side and the statusbar at the bottom (Figure 3.1)

Figure 3.1: IMUNES GUI


Image gui

The default working mode after the initial start (or after creating a new virtual network configuration file with the File $\to$ New option from the menubar) is edit mode. The edit mode is used to build and configure network topologies, contrary to the execute mode whose purpose is the network simulation. The network simulation will be explained later in the Section 4.1.3.


3.1 Toolbox

The toolbox, placed on the left side of the GUI, contains tools for building network topologies and tools for adding annotations (Figure 3.2). These tools are all available in the edit mode. In the execute mode these tools, except the Select tool, are shaded and can not be used.

Figure 3.2: Toolbox tools


Image toolbox

Each toolbox item shown in Figure 3.2, from left to right, is described below.

Selecting elements:

Building the network topology:

Adding annotations:

3.2 Menubar

The menubar consists of menus that provide access to various functions (Figure 3.3). Some options from the menubar are automatically disabled in the execute mode.

Figure 3.3: Menubar


Image menubar

3.2.1 File Menu

The File menu contains options for configuration files management (Figure 3.4).

Figure 3.4: File menu


Image file_menu

3.2.2 Edit Menu

The Edit menu contains options for handling elements on the canvas.

Figure 3.5: Edit menu


Image edit_menu

3.2.3 Canvas Menu

The Canvas menu contains options for canvas management.

Figure 3.6: Canvas menu


Image canvas_menu

3.2.4 View Menu

The View menu contains options for showing / hiding links and nodes parameters on the canvas, options for changing icon size, zooming options, etc.

Figure 3.7: View menu


Image view_menu

3.2.5 Tools Menu

The Tools menu contains the network topology management tools.

Figure 3.8: Tools menu


Image tools_menu

3.2.6 Topogen Menu

The TopoGen menu contains options for simple and fast specification of various network topologies (see Section 5.3.2).

Figure 3.9: Topogen menu


Image topogen_menu

3.2.7 Widgets Menu

The Widgets menu contains options for displaying information about the virtual network.

Figure 3.10: Widgets menu


Image widgets_menu

3.2.8 Events Menu

The Events menu - This menu is used to configure event scheduling.

Figure 3.11: Events menu


Image events_menu

3.2.9 Experiment Menu

The Experiment menu is used to start and terminate an experiment. It also enables to attach to a running experiment.

Figure 3.12: Experiment menu


Image experiment_menu

3.2.10 Help Menu

The Help menu contains the option About that invokes the About dialog box for viewing version information.

Figure 3.13: Help menu


Image help_menu


next up previous
Next: 4. Quick Intro Up: IMUNES manual Previous: 2. Introduction
Denis Salopek 2015-04-08